Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Database error

Hi,

I need help, I have created un website with 2376 Fields.

The person who is in charge of this database tell me is due to the number of fields ...

I have an error on my admin link :

- FAILED Survey Loaded:
Database error. Cannot create data table.
System Error: DBD::ODBC::st execute failed: [Microsoft][ODBC SQL Server Driver][SQL Server]La longueur de ligne de l'index 'PK__US_data1__DFB53B5CAE285D09' est sup�rieure � la longueur maximale autoris�e de '8060'�octets. (SQL-42000) [Microsoft][ODBC SQL Server Driver][SQL Server]Impossible de cr�er la contrainte ou l'index. Voir les erreurs pr�c�dentes. (SQL-42000) at D:\www\aplusainteractif.com\EI\E9195\USA\cgi-bin\admin.pl line 17, line 1.

Could you help me ?

Is there an option in Sawtooth to decrease the fields ?

Thank you
Virginie
asked Dec 17, 2015 by v.vinai@aplusaresearch.com

1 Answer

0 votes
Virginie,

There is definitely a setting for this.
1. Open the study you wish to modify
2. Click the Pencil icon in the toolbar to go to "Survey Settings"
3. Click on the "Advanced" tab.
4. Under the section "Advanced Server Settings" you can modify the number of fields to use in the database by putting a number in the field for "Max Field per Database Table".
5. I'd pick a conservative number like 700 or so (The default is more like 1400) to try to reduce the possibility both of the initial upload encountering the error you see, as well as giving you some breathing room in case you need to add or remove some questions in the course of testing/fielding the survey live. You can of course be even more conservative and use a setting like 500 if you wish. It may impact how long it takes to download the study, but should have very little impact on the experience of taking the survey as a respondent.

I hope that helps!
answered Dec 17, 2015 by Jonathan Huff Bronze (1,575 points)
Thank you very much !
...