Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Self Hosting Sawtooth Error #117

Hi, I've trying to upload a survey (made in Sawtooth 8.2.2) to a cPanel host. The web server management report keeps showing me the message "Sawtooth Error #117 File open error" It appears when the command status is "Checking database for survey name conflicts...failed". It seems to be related to perl files, since the connection status stops when "-rwxr-xr-x admin.pl" and  "-rw-r--r-- authlib8_2_2.pl". Is it because I have to specify the path to perl modules in the server? I'be trying to change the scripts of admin and ciwweb, but it doesn't seem possible. Thanks for your help.
asked May 8, 2013 by anonymous
retagged May 8, 2013 by Walter Williams

1 Answer

+1 vote
This error usually means your path file is not found or is incorrect.  Check what your survey paths are under the advanced button. You may need to provide more information such as what do you have entered for your settings (minus the passwords of course).
answered May 8, 2013 by Mike Lodder Gold (23,395 points)
Hi, I've checked the paths and they seem to be fine now. Although the connection status went beyond it got stuck before, it stops at the same point ("Checking database for survey name conflicts...failed") and shows the very same error message. I've tried to rename the paths according to the server, but it doesn't seem to work...