Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

channel and response rate

Hello everyone,
I use different channels (email, letter, social media, intranet) to recruit participants for my survey. In the final dataset, I would like to have a column "channel" that records which channel the participants used to get to the survey. This would allow me to determine the response rate of the channels. Is it possible to generate a separate survey acces link for each channel?

I assume that this is possible via a pass-in field. I would call this for example "channel" (Data type whole number?).
The value 1 then stands for e-mail, 2 for letter etc.
Do I need to code the value assignment in a freeformat question? Are there any code examples for this?

By this way I try to get the different links. For example it could look like this:
http://www.sawtoothsoftware.com/brd3/cgi-bin/ciwweb.pl?studyname=brd3&channel=1
http://www.sawtoothsoftware.com/brd3/cgi-bin/ciwweb.pl?studyname=brd3&channel=2
http://www.sawtoothsoftware.com/brd3/cgi-bin/ciwweb.pl?studyname=brd3&channel=3
http://www.sawtoothsoftware.com/brd3/cgi-bin/ciwweb.pl?studyname=brd3&channel=4

Are there easier ways to implement this?

Thanks!
asked Apr 6 by Chris (200 points)

1 Answer

0 votes
Chris, I use this method constantly in my surveys.

Sometimes it is just like your example where I need a channel type variable. At times, it could be a sample source variable (e.g. panel sample vs client sample).

So adding "channel" to the end of your survey link as a pass-in field is just fine. Define "channel" as a pass-in field and set the data type to whole number as you indicated.

Ensure the correct channel is applied to the appropriate survey link.

No need for a free format question. As long as you define "channel" as a pass-in field, that will suffice.

Click on your 4 survey links for each channel and ensure they all work correctly. Check the data too.

If you are using unique IDs (or passwords), as an alternative, you can import all IDs / passwords and channel sample in and define "channel" as a merged field. In this situation, you would setup a CSV file with 2 columns (ID / password and channel). Once you have set your sample up, import it into Sawtooth Software.  You can also check the sample has imported okay by clicking on the "Password Data" button (click the Access button at the top, select the Merged Fields tab to get there). Also click on the red tick button to check all IDs / passwords are unique. You don't need to add the "&channel=X" to the survey link when using this option. You can just use the same survey link format with the only difference being the unique ID / password.
answered Apr 6 by Paul Moon Platinum (89,880 points)
Hello Paul,
thanks for your answer.
Unfortunately, I have a problem now with the data collection for the column "channel".

I have created a passin-in field "channel" with data type whole number
I also created 4 links by adding "&channel=1", "&channel=2" etc. to the end of the survey link.
After that I hosted and tested my survey.

Unfortunately the values 1 to 4 are not stored in the column "channel".  The column is empty.
The rest of the dataset looks fine.
How can I solve this?
Thanks!
Have you named the channel variable exactly the same in your survey link and as a pass-in field?

Can you post the full survey link here for each channel?

Are you capturing an ID or password also?
Can you check your admin module now and run a frequency count on the variable "channel".

Is there any data at all?
I have downloaded the data and the column "channel" is empty in the data set of the csv file and the excel file.

I think it is due to the construction of the links. As a template I have used the survey acces link which had a "hid_" in front of the studyname. I have re-hosted the survey again.

If I design the link as before:
https://testchannel3.sawtoothsoftware.com/cgi-bin/ciwweb.pl?hid_studyname=MAStromtarif2021Dual&channel=4
the colum for channel is empty.

If I use the "One Click Link Example" as template and now delete hid_:
https://testchannel3.sawtoothsoftware.com/cgi-bin/ciwweb.pl?studyname=MAStromtarif2021Dual&channel=4
This will store a value in the channel column.  But with this version my welcome page is skipped.

update: I just added a page break in front of my welcome page. Now the welcome page isn't skipped
I noticed the "hid_" in your survey link and I just tested the survey with it removed from your survey link. That's why I wanted to check if you could see any data. So remove "hid_" from your survey link.

Also place your welcome page in a text question after the START question and you will see everything should work okay.

Can I confirm you have it all working okay now?
Yes. I just tested it again and everything looks good. Thank you for the support!
Wonderful. You have to go through these debugging experiences to learn. So now you're a little wiser when this situation bobs up next time.

So well done, and great to see you have it working.
...