Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Model Explorer Error Message

I am running a CBC and have decided not to use Holdout Tasks because they can be modeled using Sawtooth Software's Model Explorer. Now the survey is complete and I want to use Model Explorer to check the validity of my data and calculate Holdout Tasks. I set up the Model Explorer settings according to the PDF that comes with the Model Explorer zip file.

I have created a .cho file using Lighthouse Studio and read it into Model Explorer. Unfortunately, I keep getting the same error message:
"The following error occured:
An error occured readingng the utility file. The file may be corrupted or have non-numeric values (excluding the header row).
..."
I have already read in several .cho files and always get this error message. I have also read in my .cho file via the program Sawtooth Software CBC/HB, there it runs without errors.

Here (https://legacy.sawtoothsoftware.com/forum/20009/cbc-hb-model-explorer-error-message?show=20009#q20009) I read in the forum that the error occurs when there is not enough disk space available on the computer. As a result, I have freed 50GB of my hard drive, but the error remains (also on different computers).

Why can't I get Model Explorer to work?
asked Dec 17, 2020 by Ines

1 Answer

0 votes
 
Best answer
This message can also occur when the software is used in countries where the semicolon (;) is used as the delimiter in CSV files.

CBC/HB is locale-aware, and will default to writing CSV files in a locale-aware format.

The Model Explorer is pretty much an R&D project, and was not made locale-aware. It is expecting CSV files in a US-based format.

To workaround this issue, open CBC/HB and go to Edit | Preferences. There you can select the locale to use when reading or writing CSV files. Select English (US), and then shut CBC/HB down. Then the Model Explorer should work.
answered Dec 17, 2020 by Walter Williams Gold Sawtooth Software, Inc. (21,480 points)
Thank you for your quick and helpful reply! I have not thought about that. I have now changed the settings in CBC/HB and now the Model Explorer runs! Great!
...