Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Not a valid identifier' errors

I programmed a study and completed quality checking. Today, I downloaded the latest version of Sawtooth software and converted the study to latest version. Suddenly it throws 365 errors (all are 'is not a valid identifier' errors)

1. Error: Question 'Q25' - Question HTML - 'Q25RowConList' is not a valid identifier.

However, it allows to test the survey locally. If any error in a survey it should not allow to test the survey but it does. Strange!

I am really worried after getting these errors in a QC'ed survey.

I didn't do anything rather than downloading the latest version.

Please suggest
asked Nov 19 by Abdul Bronze (2,765 points)
edited Nov 19 by Abdul
Sorry to hear about this.  Would it be possible for you to share your study files with our support team at support@sawtoothsoftware.com so we can take a closer look at what's going on?
Is there a solution for this yet? I have the same problem for version 9.9.0, showing an error 'is not a valid identifier' for all CBC, free format questions, and several others (I think all of these had a underscore "_" in the name, but that may just be by pure chance).

When I open the survey in version 9.8.1, this problem does not appear.
This is the solution I received from support.

"My developer said that this is almost certainly a bug with the data layer rework. This is definitely something that will hopefully be fixed soon.

But for now, I would recommend either using the 9.8.1 version of the survey, or just using test survey instead of preview."

Your solution to the original question

Please only use this to answer the original question. Otherwise please use comments.
Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

To avoid this verification in future, please log in or register.
...