Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Alternate path to perl

In order to use Lighthouse 9, I had to install a 2nd version of perl on our server [using perlbrew].  The installation is working and test scripts are executing from a browser.

I've modified the first line of admin.pl and ciwweb.pl with the following:
#!/usr/bin/env perl

When I try to log in to the admin.html of my survey, I get the following error:

"Error:Cannot load library: authlib9_0_1.pl
Attempt to reload authlib9_0_1.pl aborted. Compilation failed in require at /var/www/vhosts/evansresearchonline.com/httpdocs/FDE/cgi-bin/admin.pl line 17. "

Is there something else I need to modify in order to use a different perl directory?
asked Jul 4, 2016 by jas8278 Bronze (750 points)

1 Answer

+1 vote
You're definitely modifying the right files, and no, there shouldn't be any other files that you need to modify, but double check the following:

The ciwweb.pl and admin.pl files that are in  
/var/www/vhosts/evansresearchonline.com/httpdocs/FDE/cgi-bin 
 need to have the updated shebang line (i.e.:  
 #!/usr/bin/env perl 
) and the shebang line has to be correct.

In this case it looks like you're relying on the new Perl executable to be in the PATH environment variables of the user running the perl scripts. The user running the Perl scripts is probably www-data.

If you know the absolute path to your new Perl executable and these other things aren't working, I'd try replacing the:
 
 #!/usr/bin/env perl 

with the absolute path of the new Perl executable created by Perl Brew.
answered Jul 5, 2016 by Jonathan Huff Bronze (1,575 points)
Shebang is correct, and I've tried the absolute path and still no luck.

What's odd is that Firefox is giving a Sawtooth error that the version of perl isn't new enough - followed by the error in my original post.  But Edge just gives me the error above
This updated version of Perl isn't used by my shared hosting solution (one of America's most popular). I've now paid for and setup a new private VPN in order to use Sawtooth and I'm still running into issues. This problem is  so bad I've started looking at other survey software.
...